Сообщение при обновлении — Not all updates can be installed

После перехода на Ubuntu 12.10 периодически стало выпадать сообщение. В принципе причина его появления известна, но так как оно появляется уж больно часто, опишу для тех кто не знает что с ним делать. Суть в том что система всячески пытается вам намекнуть, что не все репозитории совместимы.

Адрес где решают проблемму: bugs.launchpad.net

Run a partial upgrade, to install as many updates as possible.

This can be caused by:
*a previous upgrade which didn't complete
*Problems with some of the installed software
*Unofficial software packages not provided by ubuntu
*Normal changes of a pre-release version of ubuntu

Я использую «Ubuntu 12.10 alpha 1», на альфа версию перешел осознанно и

Советую до выхода стабильной версии Ubuntu отключить все кроме Cannonical.

Также советую убрать:

Обновления, не вощедшие в официальный выпуск (quantal-proposed)
Официально не поддерживаемые обновления (quantal-backports)

Также заморские друзья советуют пробелать следующее колдовство в консоли

sudo apt-get install signond
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
Остались или есть ещё вопросы? Задавайте!
(не забудьте указать ссылку на этот пост)




Оставить комментарий

Установка, настройка, мониторинг и администрирование linux, unix, windows систем